Connection issues due to internal network problem

Incident Report for PriceHubble

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 18:59 CEST

Monitoring

We've implemented a fix for the issue and are currently monitoring to ensure everything is stable. We'll continue to keep you updated.
Posted Jun 10, 2025 - 18:40 CEST

Identified

We've identified an internal network issue causing connection problems. Our team is actively working on a fix and we'll share updates as progress is made. Thanks for your patience!
Posted Jun 10, 2025 - 18:19 CEST